FRAGTrack website access issues

Incident Report for BlastIQ

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 16:23 AEDT

Monitoring

Services are restored; monitoring is on-going.
Posted Oct 29, 2025 - 15:59 AEDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 15:24 AEDT

Identified

Some users will experience issues accessing the FRAGTrack website and API's. We're actively working to restore the affected services.
Posted Oct 29, 2025 - 15:24 AEDT
This incident affected: FRAGTrack™.